- Open Vulnerability and Assessment Language -
Element Dictionary

The following is a description of the elements, types, and attributes that compose the AIX specific tests found in Open Vulnerability and Assessment Language (OVAL). Each test is an extension of the standard test element defined in the Core Definition Schema. Through extension, each test inherits a set of elements and attributes that are shared amongst all OVAL tests. Each test is described in detail and should provide the information necessary to understand what each element and attribute represents. This document is intended for developers and assumes some familiarity with XML. A high level description of the interaction between the different tests and their relationship to the Core Definition Schema is not outlined here.

This schema was originally developed by Yuzheng Zhou and Todd Dolinsky at Hewlett-Packard. The OVAL Schema is maintained by The Mitre Corporation and developed by the public OVAL Community. For more information, including how to get involved in the project and how to submit change requests, please visit the OVAL website at http://oval.mitre.org.



< fileset_test >

The fileset test is used to check information associated with different filesets installed on the system. The information used by this test is modeled after the /usr/bin/lslpp -l command. It extends the standard TestType as defined in the oval-definitions-schema and one should refer to the TestType description for more information. The required object element references an inetd_object and the optional state element specifies the information to check. The evaluation of the test is guided by the check attribute that is inherited from the TestType.

Child Elements Type MinOccurs MaxOccurs
object oval-def:ObjectRefType 1 1
state oval-def:StateRefType 0 1

< fileset_object >

The fileset_object element is used by a fileset test to define the fileset to be evaluated. Each object extends the standard ObjectType as defined in the oval-definitions-schema and one should refer to the ObjectType description for more information. The common set element allows complex objects to be created using filters and set logic. Again, please refer to the description of the set element in the oval-definitions-schema.

A fileset object consists of a single flstinst entity that identifies the fileset to be used.

Child Elements Type MinOccurs MaxOccurs
flstinst oval-def:EntityObjectStringType 1 1

< fileset_state >

The fileset_state element defines the different information associated with filesets installed on the system. Please refer to the individual elements in the schema for more details about what each represents.

Child Elements Type MinOccurs MaxOccurs
flstinst oval-def:EntityStateStringType 0 1
level oval-def:EntityStateStringType 0 1
state aix-def:EntityStateFilesetStateType 0 1
description oval-def:EntityStateStringType 0 1



< fix_test >

The fix test is used to check information associated with different fixes installed on the system. The information being tested is based off the /usr/sbin/instfix -iavk command. It extends the standard TestType as defined in the oval-definitions-schema and one should refer to the TestType description for more information. The required object element references an fix_object and the optional state element specifies the information to check. The evaluation of the test is guided by the check attribute that is inherited from the TestType.

Child Elements Type MinOccurs MaxOccurs
object oval-def:ObjectRefType 1 1
state oval-def:StateRefType 0 1

< fix_object >

The fix_object element is used by a fix test to define the specific fix to be evaluated. Each object extends the standard ObjectType as definied in the oval-definitions-schema and one should refer to the ObjectType description for more information. The common set element allows complex objects to be created using filters and set logic. Again, please refer to the description of the set element in the oval-definitions-schema.

A fix object consists of a single apar_number entity that identifies the fix to be used.

Child Elements Type MinOccurs MaxOccurs
apar_number oval-def:EntityObjectStringType 1 1

< fix_state >

The fix_state element defines the different information associated with a specific fix installed on the system. Please refer to the individual elements in the schema for more details about what each represents.

Child Elements Type MinOccurs MaxOccurs
apar_number oval-def:EntityStateStringType 0 1
abstract oval-def:EntityStateStringType 0 1
symptom oval-def:EntityStateStringType 0 1
installation_status aix-def:EntityStateFixInstallationStatusType 0 1



< oslevel_test >

The oslevel test reveals information about the release and maintenance level of AIX operating system. This information can be retrieved by the /usr/bin/oslevel -r command. It extends the standard TestType as defined in the oval-definitions-schema and one should refer to the TestType description for more information. The required object element references an oslevel_object and the optional state element specifies the metadata to check. The evaluation of the test is guided by the check attribute that is inherited from the TestType.

Child Elements Type MinOccurs MaxOccurs
object oval-def:ObjectRefType 1 1
state oval-def:StateRefType 0 1

< oslevel_object >

The oslevel_object element is used by an oslevel test to define those objects to be evaluated based on a specified state. There is actually only one object relating to oslevel and this is the system as a whole. Therefore, there are no child entities defined. Any OVAL Test written to check oslevel will reference the same oslevel_object which is basically an empty object element.


< oslevel_state >

The oslevel_state element defines the information about maintenance level (system version). Please refer to the individual elements in the schema for more details about what each represents.

Child Elements Type MinOccurs MaxOccurs
maintenance_level oval-def:EntityStateStringType 1 1

== EntityStateFilesetStateType ==

The EntityStateFilesetStateType complex type defines the different values that are valid for the state entity of a fileset state. The empty string is also allowed as a valid value to support an empty element that is found when a variable reference is used within the state entity.

Value Description
APPLIED

The specified fileset is installed on the system. The APPLIED state means that the fileset can be rejected with the installp command and the previous level of the fileset restored. This state is only valid for Version 4 fileset updates and 3.2 migrated filesets.

APPLYING

An attempt was made to apply the specified fileset, but it did not complete successfully, and cleanup was not performed.

BROKEN

The specified fileset or fileset update is broken and should be reinstalled before being used.

COMMITTED

The specified fileset is installed on the system. The COMMITTED state means that a commitment has been made to this level of the software. A committed fileset update cannot be rejected, but a committed fileset base level and its updates (regardless of state) can be removed or deinstalled by the installp command.

COMMITTING

An attempt was made to commit the specified fileset, but it did not complete successfully, and cleanup was not performed.

EFIX LOCKED

The specified fileset was installed sucessfully and locked by the interim fix (interim fix) manager.

OBSOLETE

The specified fileset was installed with an earlier version of the operating system but has been replaced by a repackaged (renamed) newer version. Some of the files that belonged to this fileset have been replaced by versions from the repackaged fileset.

REJECTING

An attempt was made to reject the specified fileset, but it did not complete successfully, and cleanup was not performed.


== EntityStateFixInstallationStatusType ==

The EntityStateFixInstallationStatusType complex type defines the different values that are valid for the installation_status entity of a fix_state state. The empty string is also allowed as a valid value to support an empty element that is found when a variable reference is used within the installation_status entity.

Value Description
ALL_INSTALLED

All filesets for XXXXXXX were found

SOME_INSTALLED

Not all filesets for XXXXXXX were found

NONE_INSTALLED

No filesets which have fixes for XXXXXXX are currently installed.